Login broken and rc.conf variables suddenly invalid after kernel/world upgrade (?!?!)

Garrett Cooper youshi10 at u.washington.edu
Fri Apr 7 04:12:29 UTC 2006

	So, I basically upgraded my source again and did installworld. Had  
to run make quite a few times because it appeared that the makefile  
for /usr/src was broken (or at least the targets were incorrect since  
it kept on complaining about stuff not being compiled in buildworld).  
So I ran mergemaster, and things appeared to be running smoothly, but  
now it appears that my system is screwed up, due to bash. Granted, I  
used bash as my login shell for both root and my local account, and  
to solve this problem I tried recompiling the program from ports in  
single user mode, but every single time I login it complains about  
not being able to find libintl.so.6 (I believe), which is a part of  
gettext. I eventually gave up on trying to reinstall and fix bash and  
gettext, but when I try and login, the stupid machine still claims to  
be missing the library, regardless of the fact that it's no longer my  
login shell and I sed'ed both /etc/shells and /etc/passwd and /etc/ 
master.passwd so that they no longer have bash in them.
	I'm just basically stumped and I need a lot of help here, because  
the machine's inaccessible (the rc 'daemon' complains all the  
variables setup in rc.conf aren't valid--although they are), and I  
would greatly appreciate any help anyone can give me.
	Thank you very much in advance!

More information about the freebsd-questions mailing list