Keyboard Issue on Dell 1850/FreeBSD

Bill Moran wmoran at
Tue Apr 4 16:59:38 UTC 2006

On Tue, 04 Apr 2006 16:54:21 +0000
"mike s. cojocea" <mscojocea at> wrote:
> I am working to install a FreeBSD 6.0 on a Dell 1850, with Dell Remote 
> Access Card.
> After the install is complete the keyboard no longer works.
> I can access the machine over SSH to do debugging. The /var/log/messages did 
> not show any error:
> %Apr  4 09:10:14 APPS01 kernel: atkbd0: <AT
> Keyboard> irq 1 on atkbdc0
> Apr  4 09:10:14 APPS01 kernel: kbd0 at atkbd0
> I tried it with FreeBSD 5.4 and it does the same thing. A Fedora Core 4 and 
> an RHEL 3 Linux did not have similar keyboard problem.
> Any help to figure this out is going to be greatly appreciated.

We've been there and done that.

In our case, building a custom kernel solved the problem - being sure
to have the required USB devices in the kernel (note that DRAC keyboards
are USB keyboards).  You may be able to accomplish the same thing with
some sort of modules or loader magic, but we wanted custom kernels
anyway, so it wasn't a hassle.

Bill Moran
Collaborative Fusion Inc.

More information about the freebsd-questions mailing list