Server time doesn't want to stay set (help!)

Bill Moran wmoran at
Mon Apr 3 18:37:59 UTC 2006

On Mon, 3 Apr 2006 13:01:09 -0400
"Steve Douville" <fbsd at> wrote:

> Geeze, this is very frustrating.  :-)
> I rebooted and went into the BIOS. It was set to the correct time. During 
> the boot process, a message comes up and says that the time has been 
> adjusted. When it's finished, the system time is 4 hours behind. I 
> immediately did tzsetup, told it that UTC was not set in the BIOS, then 
> proceeded to select the appropriate timezone. I still get:
> #web date
> Mon Apr  3 08:46:13 EDT 2006  (Note, it's 12:46 pm when I ran this.)
> web# ntpdate
> Looking for host and service ntp
> host found :
>  3 Apr 08:54:32 ntpdate[1881]: step time server offset 
> 14443.665454 sec
> The offset even shows the 4 hours my machine is behind, but it doesn't set 
> the time because the difference is too great. (I think)

That would be unusual behaviour for ntpdate, and probably constitute a
bug.  ntpdate should always set the time (unless you use -d)

Do you have a somewhat high securelevel?  From man securelevel:

 2     Highly secure mode - same as secure mode, plus disks may not be
           opened for writing (except by mount(2)) whether mounted or not.
           This level precludes tampering with file systems by unmounting
           them, but also inhibits running newfs(8) while the system is multi-

           In addition, kernel time changes are restricted to less than or
           equal to one second.  Attempts to change the time by more than this
           will log the message ``Time adjustment clamped to +1 second''.

Are you seeing messages in /var/log/messages?

Bill Moran
Collaborative Fusion Inc.

More information about the freebsd-questions mailing list