Quotas not working on FreeBSD 5.4 for amd64

Erik Norgaard norgaard at math.ku.dk
Sat Oct 22 09:29:41 PDT 2005

On Sat, 22 Oct 2005, MELVIN D. NAVA wrote:

> Recently (three weeks ago) I bought one dedicated server with FreeBSD
> 5.4-release for amd64 and I haven't been able to use quotas, after I tried
> to enable quotas in fstab over the home filesystem and rebooting, the system
> just hanged so I checked if quota was enabled on the Kernel but it wasn't...
> So I asked at the Datacenter and they told me they tried initially to enable
> quotas on the Kernel but it wasn't working at all and the server wouldn't
> start.

1. Make sure your kernel supports quota, the GENERIC kernel does 
not. You need to add this line to your kernel config and then 
compile and install a new kernel:

    options         QUOTA                   #enable disk quotas

Then reboot

2. In fstab as you know, you need to add "userquota" and/or 
"groupquota" to the options.

3. Enable or disable quota with quotaon/quotaoff

4. Edit quota for individual users or groups with edquota

I suggest that you keep quota turned off at boot so your system 
doesn't hang, then enable quotas after boot as in 3.

> I've been trying to find something like this already documented but I
> haven't found anything at all.

Did you check the handbook? Chp 16.14 seems to be for you. It is 
far more detailed than what I just wrote:


Cheers, Erik

More information about the freebsd-questions mailing list