ports: jdk15/jdk14

Micah micahjon at ywave.com
Sat Oct 8 15:41:18 PDT 2005

O. Hartmann wrote:

> Hello.
> Again, I run into frustrations when trying to install JDK14/JDK15 from 
> the ports collection.
> Operatin system is FreeBSD 6.0-BETA5, recently updated, i386 platform 
> (Dell OptiPlex280).
> Installation of linux-sun-jdk1.4.2 performed well without problems. 
> But when trying the installation of jdk14 or jdk15, I receive a SIGNAL 
> 11 running java:
> Bootstrap Settings:
>    JAVAWS_BOOTDIR = /usr/local/linux-sun-jdk1.4.2
>    BOOTSTRAP J2SDK VERSION: Segmentation fault
>    OUTPUTDIR = /usr/ports/java/jdk14/work/control/build/bsd-i586
> dmesg:
> pid 1286 (java), uid 0: exited on signal 11
> I tried using blackdown JDK, but without success, it seems tricky to 
> allow an alternative JDK.
> Any help appreciated.
> Oliver

Does the linux JDK work?  Have you tried compiling java source and 
running java classes with it?  Did you follow the directions in 
/usr/ports/java/linux-sun-jdk14/pkg-message to enable the linux procfs?


More information about the freebsd-questions mailing list