Problem with Firewall...

Kevin Kinsey kdk at
Sat Nov 26 22:59:25 GMT 2005

siva m wrote:

>     I recently installed FreeBSD 6-Release on my AMD AthlonXP box. I
>recompiled the kernel with 'cvstag=6_RELENG' with firewall enabled and
>everything went smoothly. I buildworld, compiled kernel and installed it.
>And after installing the world in single user mode, I tried to boot into
>newly installed kernel, everything seems to be fine except that there is no
>internet connection. I enabled the FIREWALL="yes" in my rc.conf and the
>firewall type I specied as 'client'. Also I specified the IP address and
>network in the 'rc.firewall' file.
>    I have a VoIP adapter at home connected through my cable modem, and my
>ethernet connection is coming out of it. I specied a static internal IP with
>a gateway.  Even when I booted my newly compiled kernel, the VoIP phone
>seems to be not working. I also have debian linux on my second harddisk and
>the internet is working fine on debian.
>   Can anyone please tell me what's going wrong? and if I am missing
>thanks in advance,

You can refer to section IV of the Handbook for some pointers,
particularly chapters 25 and 26, I'd think.

Please send diagnostic output to the list if you really want help
(and I assume that you do). 

"No network connection" is not very telling; it is only a generalization
of the problem and does not address the root cause.  We need to know
what you've tried, and what the machine has replied, before we can give
any decent advice (in short, more data is required)....

Perhaps several of the following
would give us a clue:

`netstat -nr`

`ifconfig -a`

`ipfw show`

`ping localhost`


If it *really* is the firewall, then perhaps:

#ipfw add 00001 allow ip from any to any

 ... might open things up a bit ;-)


Kevin Kinsey

More information about the freebsd-questions mailing list