sdl doesn't work

Michael C. Shultz ringworm01 at
Fri Nov 11 05:02:48 GMT 2005

For some unknow reason sdl refuses to work on my system
I've tried everything suggested on their site with no luck. Here
are a couple examples where it won't start, from a kde terminal:

qemu freeBSDminimal.img
Could not initialize SDL - exiting

from mplayer:

Playing house.s01D01a.avi.
AVI file format detected.
VIDEO:  [FMP4]  576x352  24bpp  23.976 fps  1199.9 kbps (146.5 kbyte/s)
Clip info:
 Software: transcode-1.0.0rc1
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 32.0 kbit/2.08% (ratio: 4000->192000)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
SDL: Initializing of SDL failed: No available video device.
Error opening/initializing the selected video_out (-vo) device.

note mplayer works fine when started with out -vo sdl:

vo: X11 running at 1152x864 with depth 16 and 16 bpp (":0" => local display)
Opening video filter: [noise=6t:6t]

Things I've tried:

setting DISPLAY :0.0
setting DISPLAY ringworm:0.0

Here is what Xorg.0.log shows as my video adapter:

(--) PCI:*(1:0:0) Matrox Graphics, Inc. MGA G400 AGP rev 130, Mem @ 
0xdc000000/25, 0xdfdfc000/14, 0xdf000000/23, BIOS @ 0xdfdc0000/17
xf86AutoConfig: Primary PCI is 1:0:0

Any why have ANY suggestions?



More information about the freebsd-questions mailing list