R: Re: [R] RODBC fails to build

Vittorio vdemart1 at tin.it
Wed Nov 9 14:19:04 GMT 2005

Dear All,

Thanks to the suggestion of Prof Ripley I progressively 
solved the many libraries problems connected to the installation of the 
R package RODBC under FreeBSD 5.4. 
*** As far as this OS is concerned 
*** please take notice that the sentence in the README file:".....
the configure options --with-odbc-include and --with-odbc-lib or
environment variables ODBC_INCLUDE and ODBC_LIBS to set the include
library paths as needed...."
doesn't give a complete piece of info. As 
a matter of fact, as well as setting $ODBC_INCLUDE=/usr/local/include 
and $ODBC_LIBS=/usr/local/lib I had also to put ** $LIBS=-
L/usr/local/lib ** which wasn't in the README (and wasn't that 
intuitive, was it?).
In so doing I solved the sql.h, sqlext.h headers 
problem and a successive problem with the SQLTables libraries.
This set 
things straight and RODBC was compiled flawlessly.
I think it would be 
worth your while adding this piece of information in the README file.


>----Messaggio originale----
>Da: vdemart1 at tin.it
>Data: 8-nov-2005 11.45 PM
>A: <r-help at stat.math.ethz.ch>
>Ogg: Re: [R] 
RODBC fails to build
>yes, I read it. Nevertheless I can't make head 
or tail of it.
>Can anyone out there help me with a step by step 
>Alle 17:34, martedì 08 novembre 2005, 
Prof Brian Ripley ha scritto:
>> Did you read the package's README?  It 
contains two ways to set these
>> paths.
>> On Tue, 8 Nov 2005, 
Vittorio wrote:
>> > Context:Pentium 4, FreeBSD 5.4, R 2.2.0
>> >
>> > 
I updated the extra packages I
>> > had downloaded but the upgrading of 
RODBC failed complaining:
>> >
>> > checking
>> > for unistd.h... yes
>> > checking sql.h usability... no
>> > checking sql.h
>> > 
presence... no
>> > checking for sql.h... no
>> > checking sqlext.h 
>> > no
>> > checking sqlext.h presence... no
>> > 
checking for sqlext.h... no
>> > configure: error: "ODBC headers sql.h 
and sqlext.h not found"
>> > ERROR:
>> > configuration failed for 
package 'RODBC'
>> >
>> > The two header files are
>> > present in my 
box under /usr/local/include; I tried to symlink them to
>> > 
/usr/include and to /usr/local/lib/R/include to no avail.
>> >
>> > 
Please help.
>> >
>> > Vittorio
>R-help at stat.math.ethz.
ch mailing list
do read the posting guide! http://www.R-project.org/posting-guide.html

More information about the freebsd-questions mailing list