6.0 panics on boot

Derek Ragona derek at computinginnovations.com
Mon Nov 7 00:29:34 GMT 2005

I have a computer that has been running FreeBSD 4.X and 5.X without
problems.  It runs 5.4 with no problems at all.  This system has an Intel 
845 Motherboard and chipset, Intel Pentium 4 1.6 GHz CPU, 1 GB RAM, NVidea 
GEForce MX/MX 400 video card, atapi CD-RW, IDE hard drive, standard 
floppy.  Nothing very exotic in this hardware.

I tried first to cvsup to 6.0, and rebuild everything.  The build was fine 
including a custom kernel, but when I tried to boot the new 6.0, I got a 
panic, Fatal trap 12, page fault at the NVidea driver in the boot.  So I 
re-booted the kernel.old, reverted my sources to 5.4 and rebuilt the system 
all again.

As the system rebuilt I downloaded and burned the ISO 6.0 image.

I tried to boot the ISO image and do a binary upgrade.  The CD booted 6.0 
fine, and the upgrade installed with only one error that the X.org was 
already present.  When I tried to boot the new 6.0 GENERIC kernel that was 
installed, I got the same panic/page fault error I had when I updated via 

But since the same GENERIC kernel boots fine from CD I suspect there may be 
some loader options I might need?  I'd appreciate any help with getting 6.0 
to boot without the panic.


Here is the dmesg from the last boot to give any details anyone might want 
on this system:
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD 5.4-RELEASE-p8 #1: Sat Nov  5 23:43:05 CST 2005
     root at betty.computinginnovations.com:/usr/obj/usr/src/sys/BETTY
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 1600MHz (1594.83-MHz 686-class CPU)
   Origin = "GenuineIntel"  Id = 0xf0a  Stepping = 10
real memory  = 1073479680 (1023 MB)
avail memory = 1036734464 (988 MB)
ACPI APIC Table: <D845HV HV84510A>
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <D845HV WN84510A> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
cpu0: <ACPI CPU> port 0x530-0x537 on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> mem 0xe0000000-0xefffffff at device 
0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
nvidia0: <GeForce2 MX/MX 400> mem 
0xd0000000-0xd7ffffff,0xfd000000-0xfdffffff irq 16 at device 0.0 on pci1
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
dc0: <LC82C115 PNIC II 10/100BaseTX> port 0xd800-0xd8ff mem 
0xfeaffc00-0xfeaffcff irq 23 at device 11.0 on pci2
miibus0: <MII bus> on dc0
dcphy0: <Intel 21143 NWAY media interface> on miibus0
dcphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
dc0: Ethernet address: 00:00:94:c8:52:68
dc0: if_start running deferred for Giant
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH2 UDMA100 controller> port 
0xffa0-0xffaf,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
uhci0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> port 0xef40-0xef5f 
irq 19 at device 31.2 on pci0
usb0: <Intel 82801BA/BAM (ICH2) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
uhci1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> port 0xef80-0xef9f 
irq 23 at device 31.4 on pci0
usb1: <Intel 82801BA/BAM (ICH2) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pcm0: <Intel ICH2 (82801BA)> port 0xef00-0xef3f,0xe800-0xe8ff irq 17 at 
device 31.5 on pci0
pcm0: <Analog Devices AD1885 AC97 Codec>
atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
fdc0: <floppy drive controller> port 
0x3f7,0x3f4-0x3f5,0x3f2-0x3f3,0x3f0-0x3f1 irq 6 drq 2 on acpi0
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
orm0: <ISA Option ROM> at iomem 0xc0000-0xcc7ff on isa0
pmtimer0 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
uhub2: Intel product 0x1120, class 9/0, rev 1.10/0.00, addr 2
uhub2: 4 ports with 4 removable, self powered
Timecounter "TSC" frequency 1594831964 Hz quality 800
Timecounters tick every 10.000 msec
ad0: 117246MB <Maxtor 6Y120L0/YAR41BW0> [238216/16/63] at ata0-master UDMA100
acd0: CDRW <CD-W516EB/1.0B> at ata1-master PIO4
cd0 at ata1 bus 0 target 0 lun 0
cd0: <TEAC CD-W516EB 1.0B> Removable CD-ROM SCSI-0 device
cd0: 16.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Mounting root from ufs:/dev/ad0s1a

More information about the freebsd-questions mailing list