Mounting DVD, Gnome 2.12 Browse CD and play content

Jeff Molofee nehe at
Sun Nov 6 08:09:12 GMT 2005

Hi All,

problem 1

I have been using FreeBSD as a desktop system for about 2 years now. 
Started on 4.x... as of last night, I'm now running 6 stable #2.

I've noticed over the years, that dvd, has at one point worked, then it 
stopped working, then it worked, then it stopped working, etc.

I'm not really sure what I am doing wrong... so I thought I would ask on 
this list.

If I play a dvd with mplayer dvd://1 it works fine.
If I play a dvd with totem dvd://1 it worked fine up until tonight 
(gstreamer error, not concerned about this right now because I just 
upgraded and have not had a chance to see what might be wrong).

However, if I run totem and try to play a dvd using PLAY DVD, it fails 
horribly. The error I get is:

Failed to retrieve capabilities of device /dev/cd0: Inappropriate ioctl 
for device

I have a sony dvd rw dw-d22a drive.
cam is properly configured.
permissions and mounting if devfs and fstab are set, my account is in 
the cdrom group (permission).
k3b will burn, and copy discs just fine.
mplayer will play discs (minus the menu).

I have tried to recompile totem with acd0, dvd, etc... as the DVD 
device, but it seems to ignore what I enter as a device to use and 
defaults back to cd0 (which should be fine I would think).

Any help would be appreciated.

problem 2

I attempted to mount a windows game (on dvd) the other day. I wanted to 
grab some files from the disc to play with in BSD.
when clicking the dvd icon under computer (name I gave my drive). It 
comes back and says it can't mount the disc. I am able to get a 
directory of the disc if I mount it with UDF, but I am unable to copy or 
look at the files.

Oddly enough, I can mount a dvd movie and see the contents of the drive 
just fine.

/dev/cd0 /usr/home/{homedir}/DVD cd9660 ro,noauto 0

I attempted to read a windows data dvd that I had burned a few month 
earlier and noticed I was not able to mount this disc anymore. I was 
able to mount it in the past (I fairly sure).

problem 3

this is not really a problem, but more me not understanding what I am 
doing. I read on the gnome 2.12 new features list that you can now 
double click audio tracks on an audio cd, and have them play:
Nautilus is now more tightly integrated with the multimedia tasks you 
want to do. In addition to the thumbnailing of video and previewing of 
audio in past releases, Nautilus now offers drag and drop capabilities 
from audio CDs and the ability to play a track simply by double clicking.

/How do you do this? When I try to mount an audio cd (which is what I 
would assume you would have to do to get a list of its tracks), it fails.

Sorry for the long winded post. It's my first post, and would love to 
get these problems ironed out.

Jeff Molofee

More information about the freebsd-questions mailing list