ldap + nss_ldap

cristi tauber tcristi at gmail.com
Thu Nov 3 14:33:55 GMT 2005

On 03 Nov 2005 07:20:13 -0500, Lowell Gilbert <
freebsd-questions-local at be-well.ilk.org> wrote:
> cristi tauber <tcristi at gmail.com> writes:
> > hello,
> >
> > i had a nice-working ldap server (2.2) and i decided to upgraded to 2.3(i
> > couldn't make it work with sasl). openldap-server-23 is working great,
> but i
> > want to install nss_ldap and it's complaining about this new ldap
> version.
> > nss_ldap wants openldap-client-2.2.29 but now i have
> > openldap-sasl-client-2.3.9. How do i trick nss_ldap to play with this
> > version ?
> Install nss_ldap from ports instead of whatever package you're trying
> to use. [Or provide more details about *exactly* what you did.]
> --


i made a back-up of ldap-22. i deinstall it and then i issued a

make install (chose sasl)

in /usr/ports/net/openldap23-server

and then the installation went well. next i went to


and make install

and the error is :

goliath# make install
===> nss_ldap-1.239 depends on executable: gmake - found
===> nss_ldap-1.239 depends on shared library: ldap-2.2.7 - not found
===> Verifying install for ldap-2.2.7 in /usr/ports/net/openldap22-client
===> Installing for openldap-client-2.2.29

===> openldap-client-2.2.29 conflicts with installed package(s):

They install files into the same place.
Please remove them first with pkg_delete(1).
*** Error code 1

Stop in /usr/ports/net/openldap22-client.
*** Error code 1

Stop in /usr/ports/net/nss_ldap.

that's it.


More information about the freebsd-questions mailing list