Triple booted, no mouse with in 5.4 :(

Denny White dennyboy at
Sat Jun 25 06:38:39 GMT 2005

Hash: SHA1

On Fri, 24 Jun 2005, Bill Schoolcraft wrote:

> Hello Family,
> I was totally stoked to get my first 64-bit PC, an AMD/Athlon and it
> came with Windows-XP Pro, and I did what I always do and that's to then
> install Linux then FreeBSD.  All my machines work great like this with
> the Linux bootloader doing the booting of WinXP/Linux/FreeBSD.
> The thing that bums me out is that the mouse works with WinXP and
> SuSE-9.3 but there is no luck with the mouse with FreeBSD-5.4, KDE came
> up just fine though.
> Per postings to the web I have added and removed and added the line to
> /boot/device.hints of:
> hint.acpi.0.disabled="1"
> I also "enabled" and "disabled" ACPI in the BIOS too on various
> attempts.
> I have ran:  Xorg -configure and ran the file that it generated with
> really bad results "then" deleted the generated file and made sure
> /etc/X11 was empty and with no apparent config file got a great display
> of kde when I started KDE, what file it used I don't know.  I ran a
> trace on "startx" (with a .xinitrc file containing startkde) and I
> could not seem to determine it.  I'm still used to /etc/X11/XF86Config
> but there is none in the new 5.4
> So, I really tried to find some solution to this and more or less hit a
> brick wall.
> Thanks in advance for any help on this.
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

What I'm writing is very basic, but I just got an answer
to a question where I'd forgotten a very basic thing, so
don't get insulted. I may be way off base, being a relative
newbie, but if so, it'll at least probably get a quicker
response from somewhere else. :)

1) Are you still running GENERIC kernel?

2) Do you have /dev/psm0?

3) Do you have, in /etc/rc.conf


4) Do you have, in your kernel config file,

    # atkbdc0 controls both the keyboard and the PS/2 mouse
      device		psm		# PS/2 mouse

5) Do you show something like this in dmesg?

    psm0: <PS/2 Mouse> irq 12 on atkbdc0
    psm0: model IntelliMouse, device ID 3

6) I know when you don't have /etc/X11/xorg.conf, X will
    still probe & try to come up with a working solution,
    but as to where it stores it's settings, unless in the
    afore mentioned file, I don't know.

7) And if, after running without an xorg.conf file, it does
    have one it generated, does it have anything like this?

# Identifier and driver

     Identifier	"Mouse1"
     Driver	"mouse"
     Option "Protocol"    "Auto"
     Option "Device"      "/dev/sysmouse"

8) There have been other posts about xorg.conf problems
    recently. As I said, if you don't configure it yourself,
    it'll try to probe & come up with something. I guess it's
    having trouble with your mouse, though, which, btw, you
    didn't mention what kind of mouse. Did you check the hardware
    compat list?  Hope some of this helped.

Denny White

Version: GnuPG v1.4.1 (FreeBSD)


More information about the freebsd-questions mailing list