Help, I killed my machine.

Ken Ebling ken at
Sat Jun 25 05:49:47 GMT 2005

On Jun 23, 2005, at 3:23 PM, Ben Timby wrote:

> I was upgrading from 4.10-STABLE to 5.4-STABLE, following the  
> instructions in the freebsd handbook and something went wrong.
> I used CVSup to update my sources. I built the world and kernel as  
> follows:
> cd /usr/src
> make buildworld && make buildkernel
> I am using the GENERIC config. I had to copy /usr/src/sys/i386/conf/ 
> GENERIC.hints to /boot/device.hints. Before the above builds worked  
> properly.
> I installed the kernel, and rebooted the system.
> It booted (mostly) ok, sudo did not work properly, so I had to  
> login as root. I did mergemaster -p. I had to add the new proxy  
> user and group for pf. After this, I did:
> cd /usr/src/
> make installworld
> during the process, it died in:
> /usr/src/bin/test
> with Signal 12.
> No commands worked after this point, All I received was Signal 12.  
> I cannot boot into single user mode, I receive a Signal 12 from any  
> shell I try to use.
> I understand a Signal 12 is a non-existant system call. The half  
> installworld probably caused this.
> How can I recover from this?
> Thanks.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions- 
> unsubscribe at"

I've upgraded a few machines from 4.x to 5.x without any problems.  I  
followed the instructions in /usr/src/UPDATING.  cvsup your machine  
to RELENG_5_4 and look towards the end of /usr/src/UPDATING for  
instructions.  There are a few important steps that I haven't seen  
documented elsewhere.

Good luck,

Ken Ebling

More information about the freebsd-questions mailing list