DDS Tape problems

Pavel Duda element at
Tue Jun 21 13:31:37 GMT 2005

Jerry McAllister wrote:
>>Alex Zbyslaw wrote:
>>>Pavel Duda wrote:
>>>>I have problem with my DDS-3 type drive. I'm able to write on it but 
>>>>not read data back. If I try to read them I get card dump and tape 
>>>>drive hangs up. I have tried to upgrade firmware but problem remains. 
>>>>Does somebody have experience with this ?
> We have had a lot of experience with seeing similar problems, but little 
> with solving it.   We have about 75 systems with mostly DDS-3 some are 
> DDS-4. All Are SCSI.   All were on Dell Poweredge machines and are which 
> ever vendor OEM model they were installing at the moment - but we couldn't 
> seem to identify a clear difference from one model to the next.  
> More than half seem to have been working fine for several years.
> The rest have continual problems with symptoms similar to yours - 
> it appears to write OK, but the tape is unreadable.   There appears to
> be stuff on the tape but it is junk.  I say this because skips and
> rewinds take about the amount of time I would expect,  but of course
> that is not a definitive test.   Also, sometimes I can cat or dd a file
> off the tape that is junk (eg the file is junk - not readable as anything.  
> But often I cannot get anything at all.   Some got errors during the write.
> I think there are multiple problems with the DDS drives, some of which 
> may be their own hardware on internal control and some may be the 
> SCSI controller or the drivers, but I have never been able to pin 
> anything down and after asking several questions on the lists over
> several years, have had no response other than some people agreeing
> and some stabs with additional questions to answer that all went nowhere.
> In a couple of cases, getting the drive replaced seemed to fix the
> problem.   I believe the ones that warranty replacement helped were the
> ones that failed during write.    In others I don't think rplacement helped.   
> Some sites have upgraded to DLT.
> I know none of this helps much toward solving the problem, but I post
> this response for moral support and in hopes of jogging someone who
> might know more about these things.
> ////jerry
>>>>My specs :
>>>>FreeBSD 5.2.1, generic kernel, x86 (P3), SCSI card is Adaptec AHA2940 
>>>>and tape drive Python 04106.
>>>Not terribly helpful, but I have a DAT2 working with an Adaptec 2940A.  
>>>It's worked since forever and is fine with 5.4 though I never ran 
>>>5.1/2/3.  Is the machine it's attached to dual-boot?  I.e. can you test 
>>>the tape drive in Windows, or Linux for example?  (Well, they have to be 
>>>good for something :-))   Is this a recent problem or is this the first 
>>>time you've tried using this drive?  Can you try another SCSI adapter?  
>>>I've run mine (for testing only) off the cheapest rubbish I got free 
>>>with a SCSI CDRW and it was fine.
>>I was trying to use Tekram SCSI adapter with same result. I have taken 
>>this DDS tape from my AIX machine (netfinity) where it was working wo 
>>>The only other guess would be termination.  Has anything else on your 
>>>SCSI chain changed?  Is the terminator properly plugged in?
>>Termination should be fine. I have tried both variants - termination on 
>>tape and termination via active terminator on cable.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

I've just switched tape drive for a DDS-4 and this one works fine. Funny 
is that DDS3 drive works wo problems on my workstation with Windows and 
same (well same type not exactly same) SCSI adapter. I have also found 
some information that there could be problem with SCSI commands 
queueing, but no solution for that or what it causes. Anyway now I'm 
happy that DDS-4 in server works fine so I probably wont dig deeper to 
find out where is the problem....


More information about the freebsd-questions mailing list