Unable to decipher error "ELF binary type 3 not known"

Bob Perry rperry at gti.net
Tue Jun 21 06:35:31 GMT 2005

Cvsup'd system last weekend but was unable to complete portupgrade due
to following error:
	ELF binary type "3" not known
	execution of expat-1.95.5_2 script failed, exit status 255
	ELF binary type "3" not known
	/compat/linux/sbin/ldconfig: 1: Syntax error: "(" unexpected
	*** Error code 2

	Stop in /usr/ports/textproc/linux-expat.
	*** Error code 1

The error apears while system is upgrading linux-expat-1.95.5_2 to
linux-expat-1.95.5_3.  The error continues:
	Stop in /usr/ports/textproc/linux-expat.
	** Command failed [exitcode 1]: /usr/bin/script
	-qa /tmp/portupgrade80885.59 make reinstall
	egrep: /var/db/pkg/linux-expat-1.95.5_2/+CONTENTS: No such file 
	or directory
	--->  Restoring the old version
	** Fix the installation problem and try again.

Tried to deinstall/reinstall linux-expat-1.95.5_3 but received same
error.  When I ran portupgrade -arR again, I received a Stale dependency
error recommending I manually run pkgdb -F to fix, or specify -O to
force.  I run pkgdb -F and each package which had been skipped earlier
in the upgrade due to the original error now appear in Stale dependency
scripts asking if I want to replace linux-expat-1.95.5_2.  The "score"
in the first stale dependency issue is only 31%.  Nothing confuses me
more than dealing with stale dependencies so I tried reviewing mail
archives and googling for an answer.

Does anyone have any ideas as to how I can resolve this error?

FreeBSD 5.4-RELEASE #0.


More information about the freebsd-questions mailing list