Very slow printing on 5.4 with cups anh HP LaserJet 4L

asa at asa at
Wed Jun 15 09:56:06 GMT 2005

I have a problem with very slow printing after replacing 4.1 instalation
with new 5.4 instalation (clean install, not upgrade). The printer is HP
4L, and i use it with up to date CUPS (all packages + gimp-print). With
both CUPS ang gimp-print drivers and default port settings the dokument
printing speed is about 8k each 1 minute (acording to CUPS web interface).
There are no error messages from the kernel. With hint.ppc.0.falgs="0x20"
or "0x80" there is the same effect.

With hint.ppc.0.falgs="0x20", "0x40", "0x48" and "0x88" CUPS web interface
shows taht first 32k are sent instantly. Then 'Interrupt storm detected on
"irq5: lpt0"; throttling interrupt source' kernel error message apears and
the rest of the document prints slow, as in the first example.

I tried this with several standard and HP bidirectional cables. I also
tried all possible BIOS settings for the port.

The old 4.1 instalation prints without problems.

More information about the freebsd-questions mailing list