Can't make X tunnelling via SSH work, probably loosing my mind....

Lowell Gilbert freebsd-questions-local at
Tue Jun 14 14:14:58 GMT 2005

George Hartzell <hartzell at> writes:

> I just noticed that I couldn't ssh -X from a machine into a fully
> configured jail on the same machine and have an X app display back on
> the desktop.
> I think that this used to work, but I can't swear to it.
> I've been playing around, and now have pretty much everything on the
> machine stripped down.  No jails, no ipfw, no interface aliases.
> It's running 5.4-STABLE as of a few days ago, and everything is
> compiled from ports and should be up to date.  The video cards a
> matrox 550 and I'm running with mga_drv.o and mga_hal_drv.o from the
> mgadriver-4.1 tarball from the matrox site.  It's dual headed w/ a
> pair of NEC Multisync LCD1850X's on a dual-headed DVI cable.
> It turns out that I can't ssh -X from that machine into any other
> machine and have it work.  I can, however, ssh -X from another machine
> (e.g. 5.3BETA4 laptop) into it and display onto the laptop.
> In particular, it can't even ssh -X into itself and display an X app.
> There's some information at
> including netstat and /etc/rc.conf and an ssh -v -v -X session.
> If I ssh -X into itself and run xeyes, it just sits there.  If I do a
> tcpdump -i lo0 from another window, there's a flood of traffic back
> and forth between the .ssh port and a variety of ports including
> .x11-ssh, one at 6011 [I think that the DISPLAY as localhost:11 that
> time around], and a bunch of other randomish.
> I've tried it with X11UseLocalhost on and off.
> At this point my eyes are crossed and I can't even figure out what to
> try next.  And, I'm not feeling particularl bright, I'm sure it's
> going to turn out to be something obvious....
> Anyone have any thoughts?

You're going to have problems with ssh authentication there, I would
think.  Have you tried the -Y option to ssh?

More information about the freebsd-questions mailing list