BitDefender: Libfn initialization failed

Ian Smith smiity69 at
Mon Jun 13 10:40:41 GMT 2005

Thanks for the response. The output from "ldd /usr/local/bdc/" is as follows:
# ldd /usr/local/bdc/
  => /usr/lib/ (0x281b3000)
  => /usr/lib/ (0x281d4000)
  => /lib/ (0x28079000)
  => not found (0x0)
  => /lib/ (0x282a6000)


Adi Pircalabu <apircalabu at> wrote:
On Mon, 13 Jun 2005 11:00:35 +0100 (BST)
Ian Smith wrote:

> I'm having a bit of trouble getting BitDefender working, I've tried
> installing it through the ports and by using the fetch command. Each
> time BitDefender installs without any hassle and will update fine
> when I run "bdc --update" but whenever I try "bdc --info" or "bdc --
> vlist" it does the following:
> $ bdc --info BDC/FreeBSD 5.x-Console (v7.0-2545) (i386) (Dec 22 2004
> 19:56:57) Copyright (C) 1996-2004 SOTFWIN SRL. All rights reserved.
> Error: core initialization failed: Libfn initialization failed
> I'm running FreeBSD 5.4 and using BitDefender purely as a local virus
> scanner, not for a mail server. If you would like any more info just
> send me an email.

Please post the output of the following command:
ldd /usr/local/bdc/
I think you must install FreeBSD 4.x binary compatibility libraries.
This dependency issue will be fixed in the near future.

Also, please take note that this is mainly a ports issue, therefore
future related problems should be directed to freebsd-ports at
and to the port maintainer.

Adi Pircalabu (PGP Key ID 0x04329F5E)

This message was scanned for spam and viruses by BitDefender.
For more information please visit

freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

How much free photo storage do you get? Store your holiday snaps for FREE with Yahoo! Photos. Get Yahoo! Photos

More information about the freebsd-questions mailing list