login.conf limits

Kövesdán Gábor gabor.kovesdan at t-hosting.hu
Sat Jun 11 10:46:38 GMT 2005


I've done a new class "shuser" with some limits, rebuild the cap 
database and made a new user "tester" with adduser. When it asked for 
the login class, I specified shuser, and tried to login with ssh, but it 
failed. My shuser class:

        :path=/sbin /bin /usr/sbin /usr/bin /usr/games /usr/local/sbin 
/usr/local/bin /usr/X11R6/bin ~/bin:\

After the first try I inserted those hashmarks before the modified 
lines, but it still doesn't work. Did I make something wrong?


Gábor Kövesdán

scuba at centroin.com.br wrote:

>	After doing the modfications on login.conf, run:
>	# cap_mkdb /etc/login.conf
>	Define the class for each user in passwd, using vipw. The class is
>the 5th field, in this example the class was defined as "limiteduser":
>zoruega:$1$50258.20$DdcXReDR/lhZI/1CjjEEd0:102:201:limiteduser:0:0:Zoruega Linfo,,,,X:/nonexistent:/bin/sh

More information about the freebsd-questions mailing list