new hotswap drive not seen in SCSI scan without reboot?

Dan Nelson dnelson at
Sat Jun 11 01:42:58 GMT 2005

In the last episode (Jun 10), D. Goss said:
> Experimenting with new IBM xSeries 345.  It has six hot-swap U320
> SCSI bays.  Just got another hot-swap drive/tray that is an IBM part
> to add.  I inserted drive with system up and running and then logged
> in via SSH and went to SU/root.  From there I ran sysinstall.  I went
> to partition the new drive (da2) and it was not seen - I was just
> presented with the current drives in the system (da0 and da1).  I
> tried a few more times and cycled the drive.  The LOM / remote access
> card was able to see the drive being removed and added and sent the
> corresponding alerts out.  Still I couldn't see drive so I rebooted
> system and then it was available via sysinstall.
> What am I missing please?  I would think with a hot-swap system the
> drive should be able to be found without a reboot.  I didn't try
> dropping into single-user mode, maybe that would have done it too. 
> My hope was to probe for the SCSI drive and find it while the system
> was fully up.

Try "camcontrol rescan all" to tell the kernel to rescan all the scsi
busses.  Otherwise there's no way for it to know you added a device.

	Dan Nelson
	dnelson at

More information about the freebsd-questions mailing list