new hotswap drive not seen in SCSI scan without reboot?

D. Goss lists at
Sat Jun 11 00:19:58 GMT 2005


I've been digging via Google and can't seem to find this one.  I  
think it's an easy one unless there is some hardware specificity:

Experimenting with new IBM xSeries 345.  It has six hot-swap U320  
SCSI bays.  Just got another hot-swap drive/tray that is an IBM part  
to add.  I inserted drive with system up and running and then logged  
in via SSH and went to SU/root.  From there I ran sysinstall.  I went  
to partition the new drive (da2) and it was not seen - I was just  
presented with the current drives in the system (da0 and da1).  I  
tried a few more times and cycled the drive.  The LOM / remote access  
card was able to see the drive being removed and added and sent the  
corresponding alerts out.  Still I couldn't see drive so I rebooted  
system and then it was available via sysinstall.

What am I missing please?  I would think with a hot-swap system the  
drive should be able to be found without a reboot.  I didn't try  
dropping into single-user mode, maybe that would have done it too.   
My hope was to probe for the SCSI drive and find it while the system  
was fully up.

Thanks in advance -

More information about the freebsd-questions mailing list