Problems with gif tunnels

Greg 'groggy' Lehey grog at
Tue Jun 7 08:26:18 GMT 2005

I've just installed an ADSL line, and I'm trying to route a class C
network.  For some reason the ISP does this kind of routing via a GRE
tunnel, and I'm having the devil's own job getting it to work.  Here's
the current situation:

1.  ADSL line is up and running.  I have a /30 with the following
    addresses:		gateway address		local address

2.  To this line, I want to install a tunnel for
    The ISP tells me to set up a tunnel between the local address
    ( and their tunnel address
    According to recent (5.x) documentation, this should be done with:

      ifconfig gif0 tunnel up

3.  Obviously I also need to have IP forwarding enabled.

So I do all this and get:
          inet netmask 0xffffff00 broadcast
          inet6 fe80::204:75ff:fefa:a80%xl0 prefixlen 64 scopeid 0x1 
          ether 00:04:75:fa:0a:80
          media: Ethernet autoselect (10baseT/UTP)
          status: active
          inet6 fe80::202:44ff:fe59:7076%rl0 prefixlen 64 scopeid 0x2 
          inet netmask 0xfffffffc broadcast
          ether 00:02:44:59:70:76
          media: Ethernet autoselect (10baseT/UTP)
          status: active
  gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1452
          tunnel inet -->
          inet6 fe80::204:75ff:fefa:a80%gif0 prefixlen 64 scopeid 0x5 
  Destination        Gateway            Flags    Refs      Use  Netif Expire
  default         UGS         0        7    rl0    link#2             UC          0        0    rl0       00:90:1a:40:09:98  UHLW        2        2    rl0    903
  192.109.197        link#1             UC          0        0    xl0    00:10:4b:66:1e:e9  UHLW        0     6757    xl0   1056    00:50:da:cf:07:35  UHLW        0    99336    xl0   1188    ff:ff:ff:ff:ff:ff  UHLWb       0    34521    xl0       UGHS        1        4    rl0

  net.inet.ip.forwarding: 1

I then get somebody from the other end to ping me:

  17:49:10.228597 IP > IP > icmp 64: echo request seq 6908
  17:49:11.229188 IP > IP > icmp 64: echo request seq 6909

But that's all.  Nothing goes out.  I've tried this on different
systems, and I know somebody else who is using what looks like an
identical configuration with this ISP, and it works fine.  I've tried
different systems, one and two NICs, 4.x and 5.x, all with the same
(non)result.  What am I missing?

The virus contained in this message was not detected.

When replying to this message, please copy the original recipients.
If you don't, I may ignore the reply or reply to the original recipients.
For more information, see

Finger grog at for PGP public key.
See complete headers for address and phone numbers.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-questions mailing list