Booting Process: Something real funny happening

villain villain at
Mon Jan 17 12:01:14 PST 2005


I've been trying to install FreeBSD 5.3-RELEASE (miniinst.iso) on this
HP Compaq DC7100 for a few months now. But the thing is, FreeBSD just won't
boot! I've been searching help for this high and low, in HP forums as well
as other BSD forums, with little luck.

I'm installing this on a 150GB S-ATA harddrive, and the installation goes
just fine. I've tried with the FreeBSD bootloader (BootMgr) as well as with
the standard MBR, but the result is the same: either I press F1 to boot to
FreeBSD or my machine goes through this step automatically.

And what happens next? Nothing. The computer reboots, and does the same,
over and over again. That's about it. And I've tried many things:

1) Playing with the BIOS setup, disabling ACPI and DMA settings, as well
   as looking for places to 'add a UNIX OS' but there are none.

2) Tried booting to my harddrive from the installation CD-ROM, by going to
   option 6: Escape to loader prompt. I did a lsdev and was returned:

	cd devices:
		cd0:	Device 0x0

	disk devices:
		disk0:	BIOS drive A:
		disk1:	BIOS drive C:
			disk1s1: Unknown fs: 0x7

		disk2:	BIOS drive D:
			disk2s1a: FFS
			disk2s1b: swap
			disk2s1d: FFS
			disk2s1e: FFS
			disk2s1f: FFS

   Booting like this "boot disk2s1a:/boot/kernel" is the only thing this
   loader prompt boots to, but that boots me to the installation CD-ROM :(

I actually have two harddrives. One is ad4 (believed in this case to be
the C: and the other is ad6 (the one I have Windows installed on), both are
S-ATA. Since I have a clean MBR I'm taken directly to Windows every time.

People have asked me to be more verbose on this issue, but this is as deep
as I can possibly take you!

All the best,

More information about the freebsd-questions mailing list