Trackball, extra buttons, and X - I've lost something

Mark Beaver beaverm at
Thu Jan 13 16:29:53 PST 2005

In my experience with these leave the 4 5 as your ZAxisMapping and try it
should keep your wheel working.

I'm not sure how to get the other two to work though, I've always had issues
with that.

Mark Beaver

-----Original Message-----
From: owner-freebsd-questions at
[mailto:owner-freebsd-questions at] On Behalf Of Louis LeBlanc
Sent: Thursday, January 13, 2005 7:08 PM
To: FreeBSD Questions
Subject: Trackball, extra buttons, and X - I've lost something

Ok, I've finally broken down and bought myself one of those fancy
Microsoft thumbball thingys.  I got tired of tracking my mouse around
on a 5"X5" square, which is exactly the amount of free space on my
desk right now.

Anyway, since Microsoft is a pretty good accessory company I figured
I'd check their thumbball out.  (I didn't say they were a good
software company)

I got the following immediately after plugging in:
Jan 13 17:07:31 keyslapper kernel: ums0: Microsoft Microsoft Trackball
Optical®, rev 1.10/1.21, addr 2, iclass 3/1
Jan 13 17:07:31 keyslapper kernel: ums0: 5 buttons and Z dir.

The only problem is that it has 5 buttons including the button wheel.

Give a man a hammer, he'll want to use it right?

Well, now I've got these two new hammers, and I can't get them
working quite right.

I've got the following in xorg.conf:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/ums0"
        Option      "Buttons"      "7"
        Option      "ZAxisMapping" "6 7"

This is what I used to have:
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "Buttons"      "5"
        Option      "ZAxisMapping" "4 5"

And I've restarted Xorg, and xev shows the proper button presses for
the left (button 1) and right (button 3) buttons, wheel press (button
2), and weel scrolls (buttons 4 and 5).  It also shows events for the
side buttons, 6 and 7.

I have the comand `xmodmap -e "pointer = 1 2 3 4 5 6 7"` in my
~/.xinitrc to set the buttons up, but I'm still getting odd behavior
when I roll the wheel.

So what's this strange behavior?  Well, every time I roll the mouse
wheel, I get the Fvwm Builtin menu.  I tried setting a Nop action in
the Fvwm mouse events config for buttons 6 and 7, but that breaks
scrolling with the wheel.  Now I can't seem to get scrolling back.  So
I need to figure out how to stop the menu popup without breaking the
scrolling.  Or at least get the scrolling back.

I've tried this with and without moused, but no change.  Naturally,
I change the Device above to /dev/sysmouse, and moused polls from

I'm running FreeBSD 5.3 RELEASE, Xorg 6.7.1 (built from ports) and
Fvwm 2.4.19 built with imlib support from the ports.

I think that's all.

Any ideas?

Louis LeBlanc               FreeBSD at
Fully Funded Hobbyist, KeySlapper Extrordinaire :)                     Ô¿Ô¬

  "My life is a soap opera, but who gets the movie rights?"
freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list