sendmail problem - Helo command rejected: Host not found

Matthew Seaman m.seaman at
Wed Jan 12 03:02:43 PST 2005

Srot BULL wrote:
> Hello again...
> On Mon, 2005-01-10 at 23:18 -0500, Chuck Swiger wrote:
>>Giorgos Keramidas wrote:
>>>On 2005-01-10 19:38, Chuck Swiger <cswiger at> wrote:
>>[ ... ]
>>>>Go to /etc/mail.  Edit (look for SMART_HOST), point it at your
>>>>ISP's mail server.  Do "make stop; make install; make start".
>>>FWIW, the file edited should be `', not `' otherwise
>>>a subsequent "make install" will overwrite the edited `' file
>>>with a fresh copy generated from `'.
>>Err, yes, that's right.  (I knew which file I meant.  :-)
>>Note that you can even copy to, and the system will 
>>find it for you so you don't have to change the default template file.  The 
>>Makefile explains this better than I did.
> I did edit the file /etc/mail/ and changed the line containing
> the SMART_HOST to
> define(`SMART_HOST', `')
> and
> # cd /etc/mail/
> # make stop
> # make install
> # make start
> Everything went well...
> I now have a and the all..
> But, when I tried to send an Email to my account to test if it
> is working...
> Here is what came back to my InBox:
> The original message was received at Wed, 12 Jan 2005 12:34:41 GMT
> from localhost []
>    ----- The following addresses had permanent fatal errors -----
> <srotbull at>
>     (reason: 554 <srotbull at>: Relay access denied)
>    ----- Transcript of session follows -----
> ... while talking to
> <<< 554 <srotbull at>: Relay access denied
> 554 5.0.0 Service unavailable
> <<< 554 Error: no valid recipients
> It seems that I was not allowed to relay my email so I tried the
> archives and then I tried reading the README file
> at /usr/share/sendmail/cf/README
> and found something about:
> Providing SMTP AUTH Data when sendmail acts as Client
> -----------------------------------------------------
> I read a little and did what I understood:
> 1) created a /etc/mail/authinfo file with the following
> "U:myusername" "I:myusername" "P:password"
> "U:myusername" "I:myusername" "P:password"
> Did a 
> # cd /etc/mail/
> # make stop
> # make install
> # make start
> No problems but still I can not send Emails using sendmail...
> Any hints...Or am I going the wrong direction here and probably messed
> my configuration badly now...?

No -- what you've done so far is fine.  However there are several 
possible ways for your ISP to control access to their mail server and 
you'll need to talk to them to find out exactly what you should do.

How did you manage to send the e-mail I'm replying to? I see from your 
message headers you're using the Evolution mail client, so presumably 
you've configured it to speak SMTP directly to the ISPs mail servers? 
What settings did you have to put into Evolution to make it work?  It 
should be possible to deduce from that how to configure sendmail to work 
similarly, although it may take someone more familiar with Evolution 
than I am to join up all the dots.



Dr Matthew J Seaman MA, D.Phil.                       8 Dane Court Manor
                                                       School Rd
PGP:         Tilmanstone
Tel: +44 1304 617253                                  Kent, CT14 0JL UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 372 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-questions mailing list