Unable to build

Shane Ambler Shane at 007Marketing.com
Sun Jan 9 00:24:30 PST 2005

I have just installed 5.3 release on a machine I have just put together.

Since installing I have tried to compile cvsup-without-gui and krb5 from
ports and postgresql 8.0 rc3 from the src download.

I started with cvsup-without-gui and after 16 hours I figured it was taking
too long and started to look into things.

I have installed readline and bison from ports without issue.

It seems to get stuck in a loop - I have downloaded the cvsup-without-gui
package and updated the ports and still get stuck.

I have just done 
make clean
make >> /var/debug/xxx.out

For cvsup and krb5 and you can look at the full output from

In a nutshell it seems to get stuck somewhere along the way
The following snippets seem to be roughly where it starts repeating and can
be found repeated throughout the above mentioned output files.
I seem to get 
gmake[1]: Leaving directory
gmake[1]: Entering directory
With it leaving and entering the same dir.

Does anyone know why this would happen and how to fix it?

repeat from krb5

checking for ar... (cached) ar
checking for working regcomp... (cached) yes
updating cache ../.././config.cache
configure: creating ./config.status
cd . && /bin/sh config.status ./Makefile
config.status: creating ./Makefile
gmake[2]: Leaving directory
gmake[2]: Entering directory
cd . && /bin/sh config.status --recheck
running /bin/sh ./configure  --prefix=/usr/local --enable-shared
--without-krb4 i386-portbld-freebsd5.3 CFLAGS=-O -pipe
host_alias=i386-portbld-freebsd5.3 build_alias=i386-portbld-freebsd5.3
target_alias=i386-portbld-freebsd5.3 CC=cc --cache-file=../.././config.cache
--srcdir=.  --no-create --no-recursion
configure: loading cache ../.././config.cache
checking for i386-portbld-freebsd5.3-gcc... (cached) cc
checking for C compiler default output... a.out
checking whether the C compiler works... yes

repeat from cvs

checking assembler instructions... filds fists
checking assembler GOTOFF in data directives... yes
checking assembler dwarf2 debug_line support... yes
checking assembler --gdwarf2 support... yes
checking assembler --gstabs support... yes
checking linker PT_GNU_EH_FRAME support... yes
checking whether linker eh_frame optimizations work properly... yes
Using ggc-page for garbage collection.
checking whether to enable maintainer-specific portions of Makefiles... no
updating cache ../config.cache
creating ./config.status
/bin/sh ../../gcc/gcc/configure.frag ../../gcc/gcc "m3cg" \
    "" "../../gcc/gcc/config/t-slibgcc-elf-ver
../../gcc/gcc/config/t-freebsd ../../gcc/gcc/config/t-freebsd-thread
cp config.status config.run
LANGUAGES="m3cg" /bin/sh config.run
creating Makefile
creating intl/Makefile
creating fixinc/Makefile
creating gccbug
creating mklibgcc
creating auto-host.h
auto-host.h is unchanged
rm -f config.run
gmake[1]: Leaving directory
gmake[1]: Entering directory
running /bin/sh ../../gcc/gcc/configure  --build=i386-unknown-freebsd4
--host=i386-unknown-freebsd4 --target=i386-unknown-freebsd4
a3/m3compiler/m3cc/gcc/gcc/version.c --enable-obsolete
--cache-file=../config.cache --no-create --no-recursion
loading cache ../config.cache
checking LIBRARY_PATH variable... ok
checking GCC_EXEC_PREFIX variable... ok
checking host system type... i386-unknown-freebsd4
checking target system type... i386-unknown-freebsd4
checking build system type... i386-unknown-freebsd4
checking for gcc... (cached) gcc


Shane Ambler
Sales Department
Shane at 007Marketing.com

More information about the freebsd-questions mailing list