jail /dev

Chad Leigh -- Shire.Net LLC chad at shire.net
Tue Feb 8 09:47:21 PST 2005

On Feb 8, 2005, at 8:32 AM, r p wrote:

> Hi,
> I've set up a jail and am getting confused about setting up the
> devices. The name of the jail is "jail" and it's directory is
> "/usr/jail". I am using 5.3-Release. I have tried three methods, one
> that works, two that don't.
> At the moment what I'm doing is "mount_devfs devfs /usr/jail/dev" then
> going into the jail and deleting the devices that I (think) I don't
> need/shouldn't have available. This works, but brings up the problem
> that I don't know what devices I should leave in and which I
> shouldn't.
> I tried adding the line "jail_jail_devfs_ruleset=4" along with other
> suggested lines relating to jails to /etc/rc.conf, but this resulted
> in an error message at bootup; "WARNING: devfs_set_ruleset: you must
> specify a ruleset number". I am getting the number ("4") from the
> "/etc/defaults/devfs.rules" file.

I have the following in my jail startup script

devfs_domount /local/2/hobbiton/dev devfsrules_jail
devfs_set_ruleset devfsrules_jail /local/2/hobbiton/dev
/sbin/devfs -m /local/2/hobbiton/dev rule -s 4 applyset

I am not sure which one is working but one of them is :-)   I will have 
to debug it some more and simplify this


More information about the freebsd-questions mailing list