boot problem (stage 2 boot?)

Glenn Dawson glenn at
Sat Aug 27 21:21:45 GMT 2005

At 02:13 PM 8/27/2005, Sean wrote:
>Glenn Dawson wrote:
>>At 06:04 AM 8/27/2005, Sean wrote:
>>>Just installed on a new system and I am unable to boot.
>>>Currently when that system boots it comes up with what looks like 
>>>the following example from the handbook
>>> >> FreeBSD/i386 BOOT
>>>Default: 0:ad(0,a)/kernel
>>>from my reading this is a boot2 stage
>>>booting from cd and going into Fixit it fdisk shows partition 1, 
>>>2, and 3 unused, and Freebsd is on partition 4.
>>>I thought it should be on partition 1?
>>How did you arrange the file systems when you installed.  Did you 
>>use the defaults, or your own layout?
>>The defaults would have given you 5 partitions inside of the first 
>>slice.  For example:
>>ad0s1a - /
>>ad0s1b - swap
>>ad0s1d - /var
>>ad0s1e - /tmp
>>ad0s1f - /usr
>>Did you not use the 'a' partition for your root file 
>>system?  Second stage boot code only knows how to find third stage 
>>on the 'a' partition.
>>More details on your installation would help in trying to figure 
>>out what the problem is.
>>>Note: on install I choose the Standard boot manager.
>>>I have tried playing with fdisk and disklabel to try to cure this 
>>>problem, but continually get the example shown above.
>>>With none of the above efforts working I have tried changing the 
>>>boot manager and no luck, both by reinstalling and just by using 
>>>sysinstall to modify the boot manager.I did get F1 FreeBSD when 
>>>trying the FreeBSD boot manager option, but it still did not start the system.
>I created the above partitions you listed manually and specified to 
>my choice sizes, and i did choose 'a', or entire disk on creation.

The "entire disk" option is in the screen that lest you create 
slices, which is completely different from the screen that lets you 
create your partitions. (a, b, d, e, f, etc)

Keep in mind that what is called a "partition" in other OS's is 
called a slice in FreeBSD.

You mentioned above that FreeBSD was installed in partition 
4.  Assuming that's slice 4, are the device names something like 
/dev/ads4x. where the x is the partition.

>No matter how I approach this problem I always wind up in the same place.
>I am guessing now that the MBR has a problem.

I doubt there's nothing wrong with the MBR per se, but if it's 
looking in the wrong place for the third stage loader you'll see 
exactly the problem you have.


>freebsd-questions at mailing list
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list