boot problem (stage 2 boot?)

Sean rsh.lists at
Sat Aug 27 21:13:14 GMT 2005

Glenn Dawson wrote:
> At 06:04 AM 8/27/2005, Sean wrote:
>> Just installed on a new system and I am unable to boot.
>> Currently when that system boots it comes up with what looks like the 
>> following example from the handbook
>> >> FreeBSD/i386 BOOT
>> Default: 0:ad(0,a)/kernel
>> boot:
>> from my reading this is a boot2 stage
>> booting from cd and going into Fixit it fdisk shows partition 1, 2, 
>> and 3 unused, and Freebsd is on partition 4.
>> I thought it should be on partition 1?
> How did you arrange the file systems when you installed.  Did you use 
> the defaults, or your own layout?
> The defaults would have given you 5 partitions inside of the first 
> slice.  For example:
> ad0s1a - /
> ad0s1b - swap
> ad0s1d - /var
> ad0s1e - /tmp
> ad0s1f - /usr
> Did you not use the 'a' partition for your root file system?  Second 
> stage boot code only knows how to find third stage on the 'a' partition.
> More details on your installation would help in trying to figure out 
> what the problem is.
> -Glenn
>> Note: on install I choose the Standard boot manager.
>> I have tried playing with fdisk and disklabel to try to cure this 
>> problem, but continually get the example shown above.
>> With none of the above efforts working I have tried changing the boot 
>> manager and no luck, both by reinstalling and just by using sysinstall 
>> to modify the boot manager.I did get F1 FreeBSD when trying the 
>> FreeBSD boot manager option, but it still did not start the system.
>> Thanks
>> Sean

I created the above partitions you listed manually and specified to my 
choice sizes, and i did choose 'a', or entire disk on creation.

No matter how I approach this problem I always wind up in the same place.
I am guessing now that the MBR has a problem.


More information about the freebsd-questions mailing list