cache-only named won't resolve "localhost"

Gary W. Swearingen garys at
Mon Aug 15 20:09:40 GMT 2005

Lowell Gilbert <freebsd-questions-local at> writes:

> Of course it won't work for nslookup(1); it's not supposed to.
> nslookup is specifically intended for querying a name server.  The
> documentation for host(1) isn't as clear on the subject, but my
> reading of it seems to indicate the same thing.

Well that sure explains something.  But I was also looking at the
"bind" docs thinking it should be able to read /etc/hosts or call the
name server host's resolver ("gethostbyname", etc.), but didn't find
anything, I suppose because someone thinks it is a bad idea since the
resolver library is supposed to look at both databases.

I'm still wondering if I should be declaring a forward zone for
"localhost" or "localhost.localhost"; it seems kinda strange that
the script would set up a reverse for it, but say nothing about
the forward.

I'm also wondering now what "host"-type command just queries the
resolver.  But I guess "ping" works well enough.

> So why it isn't
> working for mozilla is the only anomaly you are seeing.  What is the
> syntax you are using for pointing mozilla at your localhost, and what
> are the precise results?

I've tried:
     (getting desparate:)

This worked immediately:

The bad Mozilla results are a status line saying "Connecting to
<something>..." and, IIRC, I saw a twirly thing until it times out
after several minutes, with no error message.  I didn't see anything
related to DNS in "preferences".

More information about the freebsd-questions mailing list