cache-only named won't resolve "localhost"

Kevin Kinsey kdk at
Mon Aug 15 03:25:53 GMT 2005

Gary W. Swearingen wrote:

>I think I followed the bind manual and poked around /var/named and it
>has been working OK for a few weeks until I pointed my browser to
>"localhost" and then I tried "host localhost". It can resolve
>"" back to "localhost.localhost." fine, but if I try
>my name "localhost" or "localhost.localhost", I get this:
>   ";; connection timed out; no servers could be reached"
>(at least until I tried it just now while on-line, when it
>works OK, resolving my modem/router's localhost, I suppose).
>    ::1			localhost.localhost localhost
>		localhost.localhost localhost
>		localhost.localhost localhost
>    # Auto-generated from nsswitch.conf, do not edit
>    hosts
>    bind
>/etc/resolv.conf (same with this file missing):
>    nameserver
>I can "ping localhost" OK.
>I thought that "host" should use the same stub resolver as "ping"
>before trying "bind".
>Can I not use "/etc/hosts" with a cache-only named?
>Must I have an authoritive zone for "localhost"?
>Or what?

Did you `sh /var/named/etc/namedb/make-localhost` ?

Or, maybe I'm just not catching on.... :-(  

Kevin Kinsey

More information about the freebsd-questions mailing list