cache-only named won't resolve "localhost"

Gary W. Swearingen garys at
Mon Aug 15 00:46:22 GMT 2005

I think I followed the bind manual and poked around /var/named and it
has been working OK for a few weeks until I pointed my browser to
"localhost" and then I tried "host localhost". It can resolve
"" back to "localhost.localhost." fine, but if I try
my name "localhost" or "localhost.localhost", I get this:
   ";; connection timed out; no servers could be reached"
(at least until I tried it just now while on-line, when it
works OK, resolving my modem/router's localhost, I suppose).

    ::1			localhost.localhost localhost		localhost.localhost localhost		localhost.localhost localhost

    # Auto-generated from nsswitch.conf, do not edit

/etc/resolv.conf (same with this file missing):

I can "ping localhost" OK.

I thought that "host" should use the same stub resolver as "ping"
before trying "bind".

Can I not use "/etc/hosts" with a cache-only named?

Must I have an authoritive zone for "localhost"?

Or what?


More information about the freebsd-questions mailing list