5.2.1-RELEASE ethernet troubles

Stephen Krauth stephenk at stephenk.com
Thu Sep 23 00:37:24 PDT 2004

I'm at wits end here trying to setup a new Athlon64 machine with the
i386 release of 5.2.1-RELEASE.  The problem is getting it to like a
network card of some sort; I've tried and failed with 4 so far:

1.  Motherboard built-in NVidia gigethernet (Ok, didn't expect that
    one to be supported)
2.  Cheapo VT6105-based card using vr(4) driver:  It's recongnized in
    ifconfig but I get the dreaded "watchdog timeout" errors.  I can't
    seem to disable PnP in the BIOS per archive suggestions.  Also
    tried swapping slots, but it always shows on the same IRQ.  ACPI
    on/off doesn't matter.
3.  Slightly less cheap LinkSys LNE100TX, using dc0 driver: dmesg
    reports "MII without PHY!" error and ifconfig therefore doesn't
    see it.
4.  ANCIENT 10BaseT card using ed0 driver:  It's recongnized but
    gives "kernel: ed0 device timeout" errors.

(Sorry I can't include any dmesg output; I have no networking on the
machine.  However, it's an AMD Athlon 64 3400+ on an MSI K8N Neo
Platinum motherboard.)

So - do I have amazingly bad luck in choosing ethernet cards, or is
something else going on?  The suggestions I've found in the archives
for cards 2 and 3 above didn't work.  Any ideas at all about what I
can do to get working?  Thanks!

- Steve K.

More information about the freebsd-questions mailing list