ATI Radeon 9000 64mb AGP on 5.3beta2

John DeStefano john.destefano at
Tue Sep 21 18:18:38 PDT 2004

Ed Budd said:
> John DeStefano wrote:
> > I'm trying to get my ATI Radeon 9000 64mb AGP video card to play nice
> > with with Xorg on FreeBSD5.3beta2.  Since I've already asked for help,
> > I won't pollute the list yet again with details, as they can be found
> > at the BSD Forums:
> >
> > In a nutshell, no matter what config tool I use, or what settings I
> > come up with, when I startx I get a blue and green garbled screen out
> > from which I can't exit.
> >
> > I've been fighting with this for weeks now and I'm at the end of my
> > rope.  A few people have had some ideas, which I've tried with little
> > result.  As I'm on the cusp of deciding to reformat the whole $#@&%
> > thing and start over after a multitude of struggling (with other
> > components as well), I'm open to any and all ideas.
> >
> Have you tried it without dri and glx? I had a similar problem with my
> laptop integrated intel video and xorg running Gentoo Linux. It turns
> out that my particular card is very poorly supported by the latest xorg
> (6.8.0) but worked with 6.7.0. Now it still works but only if I don't
> allow those two modules to load, even though 'X -configure' detected the
> capability. By commenting out dri and glx from xorg.conf I've been able
> to use it, albeit without 3d acceleration.
> In any event, pretty simple thing to try. Post back whether it works or not.

I ran "Xorg -configure" and edited the fresh conf file it generated. 
One thing I noticed was that there were no screen modes at all added
to the file; Depth and Viewport were filled in, but no Modes.  So, in
addition to commenting out dri and glx, the only change I made was to
add four resolution modes to the "Depth 24" section.  I then ran "X
-config" on this new config file, and voila! I got that great, grey
screen!  Pressiong <ctl+alt+plus|minus> had no effect at all, but
<ctl+alt+back> exited out of the X server.  The one (WW) warning I saw
back on the console was "(WW) RADEON: No matching Device section for
instance (BusID PCI:3:0:1) found".  The only thing I can relate this
error to is the fact that Windows XP auto-detects this card as two
"devices" somehow as well, as it shows two cards in Device Manager
when I only have one, and a second Display too, both called

I then tried "startx" for the real test... and it failed.  It brought
me back to my favorite green and blue garbled screen, out from which I
could not exit.  Any idea why?

> Cheers,
> EB


More information about the freebsd-questions mailing list