Apache13 + mod_php segfault at startup

Vonleigh Simmons nospam at illusionart.com
Fri Sep 17 17:36:57 PDT 2004

	I keep struggling with this without finding a way of fixing it. 
Whenever I link in mod_php into httpd.conf (loadmodule and addmodule), 
apache fails to start up. I can get it to work by commenting mod_php it 
out, starting up apache, then commenting it back in and restarting. If 
I restart once more, then it segfaults again. In the logs I 
occasionally get:

[notice] child pid 17255 exit signal Segmentation fault (11)

	I've tried installing (and reinstalling) apache13-modssl, 
apache13-modperl, reinstalling /usr/ports/www/mod_php4, compiling 
apache without expat, checking ldd:

         libcrypt.so.2 => /lib/libcrypt.so.2 (0x28248000)
         libm.so.2 => /lib/libm.so.2 (0x28261000)

         libcrypt.so.2 => /lib/libcrypt.so.2 (0x28248000)
         libm.so.2 => /lib/libm.so.2 (0x28261000)

	So far nothing has been successful. I even tried installing apache2 to 
see if that would work, and although it does for the most part, it 
crashes when using the php mail() function.

	Any suggestions at all are welcomed. I'm willing to try anything at 
this point. It was all working beautifully until I did a portupgrade of 
apache and mod_php. I really wish I would've just left it alone.

Vonleigh Simmons

More information about the freebsd-questions mailing list