booting beta3 on A7N8X

Joshua Tinnin krinklyfig at
Sun Sep 12 00:10:03 PDT 2004

On Saturday 11 September 2004 04:06 pm, "Lee Harr" <missive at> 
> I have one of those goofy asus A7N8X motherboards.

I have an A7N8X-E Deluxe, and have used it with 5.2.1-RELEASE-p9 and now 
5.3 beta3. The issues I've read about with Asus mobos have been with 
the VIA chipset, which isn't on these boards, and also with ACPI - I 
have it disabled in BIOS and in the kernel. However, IIRC the onboard 
NIC is only supported in 5.x, which is why I ended up installing it 
instead of 4.10.

> Recently I found out that I can make the system boot
> 4.10-stable by disabling firewire in the kernel. Otherwise
> it freezes up while booting.

I didn't need to do that, but I don't have any firewire devices, so when 
I create a custom kernel I end up commenting that out, but it boots 
even in GENERIC for me. Do you remember if there was a specific error 
message? What's on the screen when it freezes, like what line of text 
is last?

> Today I burned a 5.3-beta3 cd and tried to boot that.
> It looks like it freezes at about the same place that 4.10
> stops, but it is hard to tell.

You should try disabling ACPI in the BIOS.

> I tried the set console=comconsole trick in the
> bootloader to try to save the boot messages from a
> serial console, but when I type that in, the system
> just immediately locks up.

Well, not sure about serial console setup ...

> So... a few questions:
> Any other tricks I might try to get this to boot? (some
>   way to disable firewire from the bootloader, maybe?)

I think ACPI might be your problem, but not sure about serial consoles.

> Is the set console=comconsole line supposed to work?
> Can I create a 5.3 cd myself from my 4.10 system?
>   (one without firewire, for instance...)

Er ... no, but you can download ISOs for 5.3 from the fbsd site.

- jt

More information about the freebsd-questions mailing list