Matthew Seaman m.seaman at infracaninophile.co.uk
Sun Sep 5 01:17:53 PDT 2004

On Sat, Sep 04, 2004 at 02:43:51PM -0500, Donald J. O'Neill wrote:

> This is not a moot point. I've been struggling with this problem 
> since this morning. The problem would just not go away.

Yes.  Yesterday morning, I cvsup'd as usual and everything happened to
work OK.  Tried again this morning, and it's back to ruby core
dumping.  What ever is triggering this appears to be quite subtle, and
it's not affecting anything else that does similar jobs with the ports

> The one I found was, on 090104 I did a portupgrade of portmanager. I 
> also had portsman installed (probablu inconsequential). I did a 
> "make deinstall" of portmanager and portsman. After that 
> portversion -rRvc worked, ruby18 was no longer seg faulting. I 
> suspect the problem had something to do with the upgrade of 
> portmanger.

As you say, removing portsmanager and portsman was probably

Unfortunately there's not a lot that can be done except to provide any
debugging info that developers ask for and to remain patient.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20040905/5d7a1fe5/attachment.bin

More information about the freebsd-questions mailing list