Donald J. O'Neill donaldj1066 at fastmail.fm
Sat Sep 4 12:44:48 PDT 2004

Hello Mattthew,

This is not a moot point. I've been struggling with this problem 
since this morning. The problem would just not go away.

After I cvsup the ports, I use "make index" and then portversion 
-rRvc. I also run script whenever I cvsup, portupgrade, or install 
a new port. On 090104 I cvsup'd ports and successfully portupgraded 
the ports (except a couple of php5 extentions and qcad, no big 
deal, I'll wait a while). On 090204 I again cvsup'd ports and 
successfully portupgraded the ports (exceptions previously noted). 
Today, I cvsup'd the ports, ran "make index", and when I ran 
portupgrade -rRcv, it went into a loop, on ttyv0 I was getting a 
message that "ruby18 uid 0: exited on signal 6 (coredumped). That 
ruby18.core file is over 10mb, would it be of use to anyone?

After several different cvsup's, and other ways to generate INDEX-5, 
all of which worked by the way, but all the ways of checking for 
ports needing updating caused ruby18 to fail. 

The one I found was, on 090104 I did a portupgrade of portmanager. I 
also had portsman installed (probablu inconsequential). I did a 
"make deinstall" of portmanager and portsman. After that 
portversion -rRvc worked, ruby18 was no longer seg faulting. I 
suspect the problem had something to do with the upgrade of 

It solved my problem anyway.

I am not investigating any further. I have other things that I'm 
trying to accomplish. However, I someone wants the ruby18.core 
file, I e-mail it. It is over 10mb and a lot of e-mail programs 
won't take an atachment that big.


Donald J. O'Neill
donaldj1066 at fastmail.fm
On Saturday 04 September 2004 09:10 am, Matthew Seaman wrote:
> On Sat, Sep 04, 2004 at 11:08:49AM +0100, Steve Hodgson wrote:
> > > FWIW, portindexdb will generate INDEX-5.db just fine on
> > > 5-current. It doesn't have the problem with ruby bus erroring
> > > like portsdb -u does.
> >
> > This also works for me on 5.2.1-p9. Am I missing something in
> > asking why couldn't "portsdb -u" be replaced by portindex?
> > Obviously this couldn't happen now with the code-freeze for
> > 5.3, but for 5.4?
> The question would seem to be moot now.  As of this morning
> portsdb is able to build an INDEX.db once again.  Although I
> cannot see exactly what was committed in order to make that work.
> Since both portindex and protupgrade are 3rd party tools, and
> neither are likely to be committed either to the base system or
> to become part of the official ports infrastructure[1], it's
> entirely up to you which one you choose.
>  Cheers,
>  Matthew
> [1] In the grand tradition of cvsup(1), it seems that any
> insanely useful tools for managing ports will be written in
> languages other than those provided as standard.

Donald J. O'Neill
donaldj1066 at fastmail.fm

More information about the freebsd-questions mailing list