[Re: Unable to write to CD-R]

Norm Vilmer norm at etherealconsulting.com
Sat Sep 4 08:10:35 PDT 2004

-------- Original Message --------
Subject: Unable to write to CD-R
Date: Fri, 03 Sep 2004 15:56:45 -0500
From: Norm Vilmer <norm at etherealconsulting.com>
To: freebsd-questions at freebsd.org

I am having trouble burning an iso image to a CD-R using FreeBSD 4.10.
I have tried using burncd , cdrecord, and  growifofs, all appear to have 
basically the same problem (see details below) "Operation not 
permitted". One thing that bugs me is that dmesg reports my drive as a 

I am not sure if this is the problem or how to addressing correcting it. 
Note: the BIOS reports the drive to be TOSHIBA DVD-ROM SD-R6112 1031, 
not a DVD-RW.

Can anyone give me some direction as to what I should try next, or
better yet, how I can get the burner working?


FYI: I read the CD-Writing Howto and several other articles and followed
the instructions therein to the best of my ability (you be the judge). 
This included:

- logging in as root;
- adding "device atapicam"  to the kernel configuration and rebuilding
the kernel;
- creating /etc/devfs.conf as follows:

link    acd0    cdrom
link    acd0    dvd
perm    acd0    0660
perm    cd0     0660
perm    pass0   0660
perm    pass1   0660
perm    pass2   0660
perm    pass3   0660
perm    xpt0    0666

- installing cdrecord, dvd+rw-tools
- ensure that the drive can read CD's and DVDs
- running ./MAKEDEV pass10 in the /dev directory

also added these


to /boot/loader.conf

mount -t cd9660 /dev/cd0 /cdrom		# works fine CD's and DVD's

Here's some things I tried:

burncd -f /dev/acd0c -s 12 data 5.2.1-RELEASE-i386-disc1.iso fixate
burncd: open(/dev/acd0c): Operation not permitted

cdrecord -scanbus
Cdrecord 2.00.3 (I386 .....
cdrecord: Operation not permitted. Error opening /dev/pass0 Cam error 
opendevice: coundn't open passthr. Cannot open SCSI driver.

growisofs -dvd-compat -speed=4 -Z /dev/cd0c=5.2.1-RELEASE-i386-disc1.iso
:-( unable to cam_open_pass("/dev/pass0", O_RDWR): Operation not permitted.

dmesg |grep DVD
acd0: DVD-R <TOSHIBA DVD-ROM SD-R6112> at ata1-master UDMA33
cd0: <TOSHIBA DVD-ROM SD-R6112 1031> Removable CD-ROM SCSI-0 device

atacontrol list
ATA channel 0:
	Master: ad0 <TOSHIBA MK8026GAX/PA001G> ATA/ATAPI rev 6
	Slave: 	no device present
ATA channel 1:
	Master: acd0 <TOSHIBA DVD-ROM SD-R6112/1031> ATA/ATAPI rev 5
	Slave: 	no device present

camcontrol devlist
<TOSHIBA DVD-ROM SD-R6112 1031>	at scbus1 target 0 lun 0 (pass0, cd0)


MB:       VIA EPIA-CL10000, 512MB RAM, Award BIOS 6.00pw
Burner:   Toshiba SD-R6112 DVD-RW

Andrew L. Gould wrote:

Were you logged in as root?

Andrew Gould

Norm Vilmer wrote:

Sorry about the last response, I think I have my mail client setup 
better for text and continuing the message at the botton rather than the 

Yes. I was logged in as root. I also played with the permissions
in /dev giving the u=rw,o=rw,u=rw, but it did not do anything so I put
the permissions back.

Is it possible the OS thinks the device is a read-only device? How Do I 
go about debugging this problem, i.e., can I find out where the problem 
is in the code? Can I get a more verbosity show why the operation is not 

Norm Vilmer

More information about the freebsd-questions mailing list