rl2 not working on otherwise functioning network/gateway

Bill Moran wmoran at potentialtech.com
Thu Sep 2 04:41:04 PDT 2004

Subhro <subhro.kar at gmail.com> wrote:
> I also faced the same problem with my packet filtering bridge. I
> wanted plug in a third NIC and assign an IP to in in order to perform
> remote administration from within the LAN. But I have come to the
> conclusion that if you start to bridge ( read put up a gateway)
> between two NICS, then it is not possible to use a third NIC to get
> things done as you say.

A bridge is different from a gateway.

I've run gateways with more than 2 NICs and the setup can be a bit
tricky, but they've worked fine.

I would suggest providing more detailed information.  For example, you
may be assigning invalid IP ranges to the NICs, but you don't say what
those IP ranges are, so I can't say.  Please post the exact commands
you used, and the exact output received.  The script(1) command can
be useful for capturing this information.

In addition, please provide complete information on all NICs, (i.e.
the complete output of "ifconfig") as well as the output of
"netstat -rn".  Also, a copy of your /etc/rc.conf will probably be

> Regards
> S.
> On Wed, 1 Sep 2004 22:42:33 -0400 (EDT), chris at voicesofopposition.org
> <chris at voicesofopposition.org> wrote:
> > Ok, if someone here can help me w/ this I will be really grateful. I
> > turned to this list after a post on a forum offering the expected advice
> > didn't help solve my problem. Basically my computer acts as a gateway for
> > my network, and it functions fine. I then decided to add another network
> > adapter so that I could add my file server to the network. But after
> > making the necessary changes to my rc.conf, I found that the network card
> > was "active", but had no IP address, and wasn't passing traffic. I'm
> > attaching my dmesg, and the output from ifconfig rl2. Here are a few
> > things I've tried to remedy the problem.
> > 
> > I tried swapping out the nic, disabling acpi, resetting the CMOS battery,
> > booting with the GNERIC kernel, and adding network information to th NIC
> > manually.
> > 
> > None of this helped. Anyway, like I said, the gateway functions for the
> > other computer on the network, so firewall and NATD are there. Here is all
> > the info

Bill Moran
Potential Technologies

More information about the freebsd-questions mailing list