gnome 2.8 mime associations

Anton Alin-Adrian aanton at
Sat Oct 2 06:42:24 PDT 2004

Joe Marcus Clarke wrote:
 > On Fri, 2004-10-01 at 20:59, Anton Alin-Adrian wrote:
 >>	I just installed gnome 2.8 from the tinderbox, and
 >>everything is great and neat, except mimes are completely broken.
 > Define, "completely broken."

Hi Marcus, I appologise for putting the problem in fast words. I really 
appreciate the fact that I can install gnome 2.8 because of your work, 
instead of waiting the ports freeze.

Maybe I did something wrong here. Nautilus is unable to open any sort of 
files, because "there is no application associated with this file type". 
This include text files, pictures, and even directories. It can't open 
simple directories, it gives the same error.

I run FreeBSD 4.10 as desktop.

For example, when I click the homedir icon on my desktop, it sais "There is 
no action associated with "bu".", and bu is my username.

The same window provides a button for "Associate Application", but clicking 
on it makes the window vanish, and nothing happens (because the applet 
which is called when this button is pushed, is not found. I found it in the 
gnome 2.6 port source, as a tool in sysutils/gnome-control-center, but 
nowhere else in the filesystem.)

Here's a sample error:

(nautilus:332): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols 
specified are supported and host-based authentication failed.

(nautilus:332): Eel-WARNING **: Error starting command 
'gnome-file-types-properties 'x-directory/normal' 'Pseudo'': Failed to 
execute child process "gnome-file-types-properties" (No such file or directory)

(nautilus:332): Bonobo-WARNING **: Leaked a total of 1 refs to 1 bonobo 

Thanks for your hard work, Marcus, and again, I appologise if I managed to 
offend you.

If I shall make snapshots, I believe it is not proper to submit them on the 
list, so please let me know, and thanks for your time again.

Alin-Adrian Anton
Spintech Systems
GPG keyID 0x1E2FFF2E (2963 0C11 1AF1 96F6 0030 6EE9 D323 639D 1E2F FF2E)
gpg --keyserver --recv-keys 1E2FFF2E

More information about the freebsd-questions mailing list