/usr out of space

Nicholas Basila mlists at northglobe.com
Wed May 19 22:50:23 PDT 2004

On Wednesday 19 May 2004 08:17 pm, hoe-waa at hawaii.rr.com wrote:
> When I tried using bsdlabel without any options I got an error.
> So I then did a "bsdlabel -w da1s4" and the a "bsdlabel -e da1s4"
> and edited what I believe are the correct numbers for this slice.
> Now when I do the "bsdlabel da1s4" with no options, I get
> # /dev/da1s4:
> 8 partitions:
> #        size   offset    fstype   [fsize bsize bps/cpg]
>   c:  8980335        0    unused        0     0         # "raw" part,
> don't edit f:  8980319       16    4.2BSD     2048 16384 28552
> I still get the above error when trying to mount this slice.
> To sum it up.
> Is it possible to mount, copy and change the /usr partition?
> If so, how do I correct the super block problem so I can mount?
> Or, is there a much easier way and I have been spinning my wheels for
> the last 6 hours?

	Perhaps I've missed a step, but it seems that you never did a newfs /
dev/da1s4f. If not, that would be an obvious explanation for the 
incorrect super block error.
	At any rate, it is pretty easy to copy data from usr to a new slice and 
change fstab. I do it on occasion. I would recommend making a copy of 
fstab that has the da1s4f as the /usr partition. 
	I do a tunefs -n enable on the new filesystem device. Then, I boot into 
single user mode, mount -ro /usr and mount -rw /newusr (and I even 
mount /var if I need to do editing with vi.) I then tar or copy the 
files over (dump works, too). After all that's done, umount /usr and 
umount /newusr. Copy the new version of fstab to /etc/fstab, and try a 
mount /usr or mount -a. If there are no errors, you should be able to 
hit control-d and finish the boot procedure. 


> Robert
> P.S. Here's what bsdlabel on da1s2 looks like;
> bsd-desktop# bsdlabel da1s2

More information about the freebsd-questions mailing list