Gettytab problems

Lefteris Tsintjelis lefty at
Tue May 11 05:52:38 PDT 2004

Just for the record, replacing ttydX with cuaaX in /etc/ttys worked as 
should and solved the problem, so I guess the "man gettytab" needs 
either updating or something is wrong with the ttydX device driver.

Lefteris Tsintjelis wrote:
> Hi,
> I am using the 4.10-PRERELEASE and trying to set up a plain old serial
> modem using getty but with no success. I get a "getty: modem init/answer
> problem on /dev/ttydX" all the time.
> :ac=RING\r ATA\r CONNECT:\
> :ic="" ATE1Q0V1S0=0\r OK\r:
> It seems the problem is the ac and ic entries even though a "man gettytab"
> is referring to them. The "dc" (chat debug bit mask) doesn't seem to help
> either. Setting the S0=1 (auto answer) works OK but is there a way to
> wait for the "RING" (for indefinite time) and then issue the ATA? Has
> anyone managed to use the ic/ac capabilities of gettytab and provide a
> working sample?

More information about the freebsd-questions mailing list