[samba] can't print from w2k to bsd printer

Bjarne Wichmann Petersen freebsd.nospam at mekanix.dk
Sun May 9 13:06:23 PDT 2004


I've spend several hours trying to get samba to play nice. I can get user to 
login from windows to their bsd-account, mount CD's etc.. But I can't get the 
users to print. I can see the printer and I can install it. But when I click 
on the installed printer I get "access denied". 

I've tried everything, dublicating every smb.conf I could find. Trying out 
every options. None helped. Hope someone here can spot what's wrong.

My setup is a desktop PC running FBSD and a laptop with w2k. These are 
connected through a router. The printer is a laserjet and works great on the 

And I'm a newbie to samba.

/etc/printcap (using fbsd's native lpr):

laserjet|lp|ps|PS|S|hp|HP LaserJet 1200:\

/usr/local/etc/smb.conf: (as it looks right now).

  netbios name = fbsd
  server string = "Samba Server"
  workgroup = WORKGROUP
  security = share
  encrypt passwords = yes
  wins support = yes
  printing = bsd
  printcap name = /etc/printcap
  load printers = yes
  use client driver = no

  comment = All printers
  printable = yes
  path = /var/spool/samba
  browseable = no
  public = yes
  read only = yes
  writable = no

  comment = LaserJet 1200 on FreeBSD
  path = /var/spool/samba
  browseable = yes
  printable = yes
  writable = no
  hosts allow = 192.168.1.
  guest ok = yes

Permission on /var/spool/samba:

drwxrwxrwt  2 root   wheel   512 May  9 21:35 samba

I've tried 2 ways of installing the printer on w2k. 1) Clicking on the 
printericon in the local shares folder and 2) "add new printer" and selecting 
the printer from the network. Both ways gives me "access denied" after 

Help! ;)


More information about the freebsd-questions mailing list