Boot loop in FreeBSD 5.2-RELEASE after install

Mike Newell mnewell at
Fri Feb 20 09:44:40 PST 2004

On Fri, 20 Feb 2004, Tony Frank wrote:

tfrank> I saw the crash/assert type scenario if the boot blocks are not installed
tfrank> properly.
tfrank> Ie the MBR is updated with the bootmgr (F1 .. bit) but the 2nd/3rd stages
tfrank> were corrupted somehow.
tfrank> (In my case I accidentally overwrote the blocks with some experiementation)
tfrank> You can reinstall boot blocks using bsdlabel (or disklabel on 4.9)
tfrank> If you can boot from floppy/CD, get into fixit mode.
tfrank> Then run:
tfrank> bsdlabel -B da0s1 (assuming da0 is the disk you are trying to boot from)

I had tried re-writing the MBR in a number of ways.  This one didn't
succeed either...  Sigh...

It's clear I'm getting to the /boot/loader program and it's running; it
just keeps looping with no indication of an error (until it runs out of
heap, which is the assertion failure).

Do you know if there's a method of bypassing the loader program and
directly booting the kernel?  I tried stopping the second stage boot and
booting "/boot/kernel/kernel".  The boot program spins for a (long) while
loading it, but I'm guessing something's missing 'cause once it transfers
control to the kernel the system freezes.

tfrank> Have you tried 4.9-RELEASE on this system?

No, I have several other 5.2 systems (built from these same CDs) and I
kind of wanted to minimize the number of variants.  This IS the only
dual-drive SCSI-only box I have going though...  Maybe I should just slap
an IDE drive into the box (there's space and even cabling available) and
install to that???

tfrank> I understand that 5.2.1-RC2 ISO is also available which might be another option.

I know - it came out the weekend after I downloaded and burned the 5.2
ISO.  Grrrr.... :-)



More information about the freebsd-questions mailing list