kdelibs3 configure script reports LibXext error

Michael Dunham m.dunham at connectingteams.com
Wed Feb 11 16:08:00 PST 2004

OleVo wrote:

Subject: kdelibs3 configure script reports LibXext error
To: freebsd-questions at freebsd.org
Message-ID: < at>
Content-Type: text/plain; charset="us-ascii"; format=flowed

I'm trying to install the KDE3 which came with freeBSD 4.9 from ports.
Unfortunately the installation fails while installing the kdelibs3 with the 
following error:

----------------Snip ----------------------------
I had a very similar error on 5.1 Current which I solved after a lot of trial 
and error, and of course emails to lists.  There is good information on this 
on the FreeBSD at KDE page and the freebsd-ports mailing list. 

My email which is also posted to the ports mailing list follows:

----------  Forwarded Message  ----------

Subject: Success - KDE 3.2 running on FreeBSD 5.1 Current
Date: Wednesday 11 February 2004 09:23 am

I had some problems upgrading to KDE 3.2 that I was helped through by
Michael Nottenbrock and the FreeBSD at KDE homepage
(http://freebsd.kde.org/).  As the homepage points out, there have been
several changes to the structure of KDE to reach the 3.2 release so it
is not as easy as doing a portupgrade -a to get everything up to date
(and that's really not the best way to interrelated upgrades anyway).

Here's what I had to do:
Once you have updated your ports tree, you can portupgrade kde (the
master port) to 3.2 without a problem. If you go beyond that, you will
begin to have failures unless you follow a careful path...

In serial fashion - meaning one at a time, not in parallel.
Update the ports tree (!!)
portupgrade -f  XFree86-libraries
portupgrade -f  gmake
portupgrade -f qt
make deinstall kbase (in the kbase3 directory)
portupgrade -f kdelibs
Do a make install of kbase
At the point where you have gotten through the upgrade/reinstall of qt
you can start these tasks in another session in parallel:
make deinstall  kdenetwork (in the kdenetwork directory)
either install or  portupgrade -f  kdepim
make install kdenetwork (I did this in parallel with the upgrade of
kdepim and had no problem)
If  you are doing this in sessions as a super user from X, logout of X
and restart your X/KDE session.  If you are doing this from the command
line, no problem - you should now be able to start X and/or continue to
update the rest of the KDE related ports.

I had to use the "force" (-f) option in all of these because I had tried
several approaches before I got this one to work.  You may be able to
stop using it once you have gotten past the forced upgrade of qt and a
lot of this method depends on the state of your port tree when you
start.  But using the force won't change the fact that if the port needs
an update it will be upgraded, if it doesn't it will be reinstalled.
Either of those outcomes will solve the problems as long as you step
through in the proper order..

If you have been playing around trying to get it work before you read
this, you may have to do a portsclean -CDLP and then force a new port
database (pkgdb -fu) to be put together before you do your last update
to your ports tree.  In any case, it can't hurt.

After you have completed this series of upgrades and reinstalls, you can
upgrade the rest of the KDE related ports.  I tried to use the addons
master port kdeaddons but it failed right away trying to upgrade
atlanticdesigner (a game).  I went around it and have been upgrading the
other related ports without a problem.   Why kdegames would upgrade and
kdeaddons would halt in upgrading the kdegames I don't know.

That's it!




Make your Information your KnowlEDGE 
Michael L. Dunham 
Principal Consultant 
Connecting Teams 
2333 La Lima Way 
Sacramento, CA 95833 
Phone: 916-641-1204
email: m.dunham at connectingteams.com 
webpage: http://www.connectingteams.com

More information about the freebsd-questions mailing list