FreeBSD on Laptop

rfa at rfa at
Tue Feb 10 06:11:32 PST 2004

hi kris,

i was in the process of upgrading my kernel from 5.0 Release to 5.2 (on my
laptop) and it won't boot. my boss gave me these instructions:

#cd /usr/ports/net/cvsup-without-gui && make all install clean
#cp /usr/share/examples/cvsup/stable-supfile /etc/stable-supfile
change default host -> cvsup10 or cvsup13
#rm -rf /usr/src
#cvsup -g -L 2 /etc/stable-supfile
#cd /usr/src && make world
#make buildkernel KERNCONF=GENERIC
#make installkernel KERNCONF=GENERIC

when it boots up, wait for it to pause and press ESC "boot -s"
---->>this is where it stops<<-----

#cd /usr
#fsck -p
#mount -u /
#mount -a
#cd /usr/src
#adjkerntz -i
#mergemaster -p
#make installworld
press "yes" and press "i" whenever it prompted you
repeat ur steps
#mergemaster -p
try to press "no" if there is a yes/no something
just press the letter "i"
delete what is left of /var/tmp/temproot

when it stops up, the messages from the boot script end like this:

mounting root from ufs:/dev/ad0s2a
pccard: card inserted, slot 1
pccard: card removed, slot 1
pccard: card inserted, slot 1

i traced the problem to the pcic device(pc card duh!) and i want to
disable it. How can i do this?

i tried unset but cant get it to work.
   unset pcic0
   unset hints.pcic
   unset pcic1 (although it was disabled na)
also i tried
boot kernel.old
that didnt work.

i got to this point after TONS of reboots and searching thru man pages on
the devices show() says.

hope you can help! =)


> 5.0 is by now very old; you should try a modern release.  5.2.1 is due
> out soon, so you might like to wait for that.
> Kris

More information about the freebsd-questions mailing list