hostap TX fix in 5.x

Scott Pilz scottp at
Wed Apr 28 12:45:50 PDT 2004

	Has anyone found a fix for this problem yet?

Affects: In FreeBSD-5.x / Current
Card Used: Prism 2.5, tried all firmware (from 1.3.9 to 1.7.2)

While the interface (wi driver) is set to hostap, associated clients can
upload at 11mbit/sec but download a maximum at half of that (I'm seeing a
maximum being around 180KB/sec).

Running FreeBSD 4.9 with the same card works fine (500-600KB/sec both up
and down) while in hostap.

Adhoc in 5.x and 4.x work fine at full speeds.

As far as I can tell the problem deals with the wi(4) driver.

I've confirmed this with the usage of over a dozen prism 2.5 PCMCIA cards
of various versions of firmware (primary & station). Heres the current
versions I've tried:

Intersil Firmware: Primary (1.1.1), Station (1.7.4)

	There has not been a lot of talk on this, but there are some
(short) discussions out there that end up being a dead-end.

	Anyone have any comments/suggestions/heard anything more than I



More information about the freebsd-questions mailing list