mouse in FreeBSD

Bill Moran wmoran at
Wed Apr 21 05:02:03 PDT 2004

ilich wrote:
> Hello All!!!
> I have problem wiht my mouse in X.
> When X was loaded, the cursor of the mouse Has escaped to the right top corner. When I moved a
 > mouse the cursor on the screen did not move.
> To begin with I have edited my /etc/rc.conf file and have added following lines:
> -----------------------
> moused_enable="YES"
> moused_port="/dev/psm0"
> moused_flags="-z 4"
> -----------------------
> in order on to use a mouse in console.

Does the mouse work in the console?  If not, then the advice I give below doesn't
apply, and your moused config is wrong (although it looks correct from here).

> After I have tryed to start X, but has received the message "Device busy" then 
> I have edited the input section in XF86config with the following:
> ------------------------------------
> Option      "Device" "/dev/sysmouse"
> Option      "Buttons" "5"
> ------------------------------------
> And I have tried to start X again. It has loaded. But mouse did not move.
> What happened with a mouse in X?

I expect you have the wrong protocol for the mouse.  Try adding:
Option "Protocol" "Auto"

which worked for me (I have a Logitech dual-lazer mouse with 5 buttons and
a massage attachment)

If that doesn't work, do a little research on the specific brand of mouse
you have to see what Protocol setting will work.

Bill Moran
Potential Technologies

More information about the freebsd-questions mailing list