Microsoft wireless mouse problem

10,000 Screaming Monkeys bsd at
Fri Apr 16 18:44:01 PDT 2004

I tried sending this to freebsd-hardware, but nobody replied, so I
thought I would try here, as well.

On one of my machines, I'm running FreeBSD 5.2-CURRENT (last built on
Jan 15th, 2004).

I recently purchased a "Microsoft Wireless Optical Desktop," which is a
wireless setup with a PS/2 keyboard and a USB mouse (with a USB->PS/2
converter, if I need it).

The system recognizes both the keyboard and mouse during boot (and the
keyboard actually works right from the loader):

] ums0: Microsoft Microsoft Wireless Optical Desktop\M-. 1.00, rev
] 	2.00/73.73, addr 2, iclass 3/1
] ums0: 5 buttons
] atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
] atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
] kbd0 at atkbd0

The system also correctly detects when the USB mouse is unplugged and
plugged back in:

] ums0: at uhub0 port 1 (addr 2) disconnected
] ums0: detached

moused starts just fine (automatically) during the system boot, and
XF86, using /dev/sysmouse, starts without complaining about anything.
"XFree86 -config" detects the mouse as sysmouse, as well.

Unfortunately, the mouse doesn't respond at all. On the console & in X,
I get the mouse pointer in the center of the screen, but it doesn't
respond to the movement of the mouse. 

When I plug in a regular, non-wireless USB mouse (an IntelliMouse
Explorer, to be precise), it's detected as /dev/ums1 and works just fine
both on the console (with moused running) and in X.

] ums1: Microsoft Microsoft 5-Button Mouse with IntelliEye(TM), rev
]	1.10/3.00, addr 3, iclass 3/1
] ums1: 5 buttons and Z dir.

So, I'm assuming my kernel & USB configurations are correct.
I've tried killing moused and starting X using the ums0 device directly,
but that didn't work either. 

Plugging the mouse cord on the wireless receiver into the PS/2 mouse
port doesn't seem to have any effect on the matter -- the system detects
a mouse on the psm0 port, but it still doesn't respond to movement.

Has anybody else seen a similar problem? Any suggestions as to what to
do next? Nothing I've tried seems to be working and I could use all the
help I can get...

- Jamie

More information about the freebsd-questions mailing list